SR Idling problems: EVAN, MARTY, ANYONE?!

Have problems with your car? Have questions about the inner workings of your car and/or would like to know theories and technical aspects of how things work, ask away here!

Moderators: Nismo, 13th-Angel, Axlerod

SR Idling problems: EVAN, MARTY, ANYONE?!

Postby DJPyro on Wed Apr 30, 2008 4:53 pm

Hey guys,

Just finishing up the beast for another season, and I'm having a bit of an issue with my idle.

For some reason it doesn't like idling, it seeks a bunch, and even when it settles down, there's no vac at idle... It revs fine, pulls hard, and builds boost just fine. I've looked over and over again to find vacuum leaks and haven't seen any.

It will build vacuum just fine when it seeks around, but even then it's only getting like -10mmHG.

Is it possible it's my IACV? And how do I go about fixing it? The car runs fine and pulls strong, just doesn't want to idle... Also, when I rev it at a stand still it sounds almost like it's misfiring or something... I'll try to get a vid up later.
Wishin' for a coupe...
User avatar
DJPyro
Primary Driver
 
Posts: 635
Joined: Thu Aug 24, 2006 3:23 pm
Location: Sault Ste. Marie, ON

Re: SR Idling problems: EVAN, MARTY, ANYONE?!

Postby Nave on Wed Apr 30, 2008 10:50 pm

Is it hunting around but running properly when it passes the "normal" idle speed or is it running poorly, like a misfire, all the time? Can you hold it at a steady idle with the throttle cracked just a little bit? Say it idles at 750rpm, can you hold it at a steady 900 and it run perfect? What did you do before this happened? How have you checked for vacuum leaks?
- 90 Coupe a la SR
- 90 Coupe a la KA
User avatar
Nave
NEO Member
 
Posts: 3189
Joined: Wed Sep 10, 2003 6:56 pm
Location: Ottawa, ONT

Re: SR Idling problems: EVAN, MARTY, ANYONE?!

Postby DJPyro on Wed Apr 30, 2008 11:28 pm

No discernable vacuum leaks, but I'm gonna replace all the lines and put new clamps on them all anyway, as I'm unimpressed with they way they're routed right now.

Adjusted my IACV, and now it'll idle ok, still dips and dives a bit when I drop off the throttle. And still no vacuum, must be leaking at some of the fittings, but as stated, I'm replacing all the lines so it should hopefully resolve that issue.

It'll hold RPMs just fine Evan, and it'll rev just fine, though I think the timing may be off, since it's not as snappy as it should be. I heard an SR in too long, so I'm up in the air as to whether it's misfiring at all, or just the sound of a crackly 3" exhaust, and the bog is timing related...

TPS is in normal operating voltages.

I think it's just a combination of a bunch of very small vac leaks, and my base timing is probably off since I set it when it was hunting around for idle.

I'll update closer to the weekend after I have the chance to poke at it again.
Wishin' for a coupe...
User avatar
DJPyro
Primary Driver
 
Posts: 635
Joined: Thu Aug 24, 2006 3:23 pm
Location: Sault Ste. Marie, ON

Re: SR Idling problems: EVAN, MARTY, ANYONE?!

Postby DJPyro on Fri May 02, 2008 3:42 pm

Ok, you guys are gonna fucking *love* this one lol....

Wandering idle, *and* most of the vac problem was due to my throttle cable bracket having been bent ever so slightly, causing the throttle plate to not close completely... As soon as I adjusted that, my idle calmed down to 750rpm where it should be, and I'm getting about 10-15mmHG vac.... Still not perfect, but about where it was last season. I re-did all my vac lines on the front of the motor, so I think that improved things a bit, but the throttle cable was the main culprit.

Timing is off just a bit now, so I need to re-set that, but apart from that she's just about good for the road :D
Wishin' for a coupe...
User avatar
DJPyro
Primary Driver
 
Posts: 635
Joined: Thu Aug 24, 2006 3:23 pm
Location: Sault Ste. Marie, ON

Re: SR Idling problems: EVAN, MARTY, ANYONE?!

Postby Nismo on Sat May 03, 2008 1:56 pm

Wow... nice find.
"Don't put the power on, till you know you never have to take it off" -- Sir Jackie Stewart
Image
User avatar
Nismo
NEO240SX Co-founder
 
Posts: 15644
Joined: Thu Nov 08, 2001 6:01 am

Re: SR Idling problems: EVAN, MARTY, ANYONE?!

Postby DJPyro on Sat May 03, 2008 2:46 pm

Yeah, it was just by chance... I decided to check my base timing to see if that was why it was a bit more broken up when revving than usual, and the idle started to wander, so I snapped the butterfly a few times to bring it down, and just happened to notice it moved an extra 1/16th of an inch down, so I pushed it down and the idle calmed right down, and my vacuum came back... Adjusted the throttle cable bracket and voila, I have vac and a smooth 750rpm idle. :D:D
Wishin' for a coupe...
User avatar
DJPyro
Primary Driver
 
Posts: 635
Joined: Thu Aug 24, 2006 3:23 pm
Location: Sault Ste. Marie, ON


Return to Technical Questions


Who is online

Users browsing this forum: No registered users and 1 guest


cron