Engine Problem - Expert Opinion needed

Have problems with your car? Have questions about the inner workings of your car and/or would like to know theories and technical aspects of how things work, ask away here!

Moderators: Nismo, 13th-Angel, Axlerod

Engine Problem - Expert Opinion needed

Postby Ninja0n3 on Fri Jul 03, 2009 8:17 pm

Last week I checked the oil and put some in there.
Anyways, today I ran into the following problem: I started smelling a strange smell, like something heated. I check my oil and it was empty.
I also noticed the engine was making a constant noise, I am however not sure where it is coming from.
It is not a cluncking noise at all, but the kind of noise a loud running fan would do; this noise seems to be coming from inside the block. The sound would get louder with the revs (I could hear it go louder when I turned on the fans for the interior.)

What is really worrying me about this is the smell, which went away after I refilled the block with oil, but came back by the time I got home.

I would really appreciate it if you guys could give me your honest opinion on this, and more importantly how badly or not I managed to damage my engine aside from the obvious oil leak problem.

Thanks a lot.
Jamil
240SX SE Zenki S14
DRIFT_evolution
Image
User avatar
Ninja0n3
LED Sepcialist
 
Posts: 1558
Joined: Tue Sep 13, 2005 1:23 am
Location: Hull/Gatineau

Re: Engine Problem - Expert Opinion needed

Postby Nismo on Fri Jul 03, 2009 11:00 pm

I would say it needs to be seen in person before anyone can really take an honest stab at what the problem could be.
"Don't put the power on, till you know you never have to take it off" -- Sir Jackie Stewart
Image
User avatar
Nismo
NEO240SX Co-founder
 
Posts: 15644
Joined: Thu Nov 08, 2001 6:01 am

Re: Engine Problem - Expert Opinion needed

Postby Nave on Wed Jul 08, 2009 3:13 am

I agree with Alex, I would have to hear it. Is it still driveable?
- 90 Coupe a la SR
- 90 Coupe a la KA
User avatar
Nave
NEO Member
 
Posts: 3189
Joined: Wed Sep 10, 2003 6:56 pm
Location: Ottawa, ONT

Re: Engine Problem - Expert Opinion needed

Postby Ninja0n3 on Wed Jul 08, 2009 9:36 am

It is still drivable, at least up until the battery gives up (I believe it still has some juice left) given my alternator has died and it's not recharging.
Changing that first, I'll give you an update.
Jamil
240SX SE Zenki S14
DRIFT_evolution
Image
User avatar
Ninja0n3
LED Sepcialist
 
Posts: 1558
Joined: Tue Sep 13, 2005 1:23 am
Location: Hull/Gatineau

Re: Engine Problem - Expert Opinion needed

Postby Jonweir on Mon Jul 20, 2009 8:49 pm

Not sure about the smell, but a loud fan noise linked to engine RPM could be clutch fan failure. Assuming s14 uses a clutch fan...?
Hot brontosaurus having breakfast:
Image
Jon.
User avatar
Jonweir
NEO Original Crew
 
Posts: 924
Joined: Fri Oct 11, 2002 12:24 am
Location: Toronto, ON

Re: Engine Problem - Expert Opinion needed

Postby Ninja0n3 on Tue Jul 21, 2009 1:11 am

Actually,
Problem was fixed as soon as I changed my alternator.
The old one was ceased so the pulley was not spinning. I'm pretty confident both the smell and the noise came from the rubbing against the ceased pulley of the alternator.
Smell and noise are both gone.

Thanks for the help.
Jamil
240SX SE Zenki S14
DRIFT_evolution
Image
User avatar
Ninja0n3
LED Sepcialist
 
Posts: 1558
Joined: Tue Sep 13, 2005 1:23 am
Location: Hull/Gatineau


Return to Technical Questions


Who is online

Users browsing this forum: No registered users and 1 guest


cron